Проблема с vmware

Статус
В этой теме нельзя размещать новые ответы.

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28
Суть такова. Поставил сервер 1.4.5 на вмваре. Всё работает. Но не могу никак сделать,чтобы другие люди могли регистироваться\заходить на сервер. У них тупо не работает сервер.Подскажите что делать?
 

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28

Глеб

Aller2TeaM
Пользователь
23 Июн 2012
41
7
8
29
vk.com
Я тоже так подумал. Именно на виртуалке? Если да,то я пробывал iptables,но у меня не выходит,или у меня руки кривые.

как вариант попробуй chmod 777 -R /var/www/
не знаю как у вас, но у меня когда я пытался зарегаться со своего компа было всё ок, а когда с другого писал permissions denied или что- то такое, это помогло.

+ ещё как вариант отключить полностью файрволл: http://www.cyberciti.biz/faq/turn-on-turn-off-firewall-in-linux/ и посмотреть, получится ли. Если нет, то включаешь обратно, инструкция там же.
 

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28
как вариант попробуй chmod 777 -R /var/www/
не знаю как у вас, но у меня когда я пытался зарегаться со своего компа было всё ок, а когда с другого писал permissions denied или что- то такое, это помогло.
У других вообще страничка не открывается. Дело в портах на виртуалке скорее всего. Т.к когда ставил на колинукс, всё было хорошо. Но у меня сейчас семёрка х64. Может кто написать как правильно там открывать порты?
--- добавлено: 30 июл 2012 в 17:51 ---
Спасибо за ответ. Как всё попробую,отпишу.
 

Juzilkree

Злостный отаку
Команда форума
Администратор
29 Ноя 2012
1.943
731
158
37
www.dyndev.ru
как вариант попробуй chmod 777 -R /var/www/
так делать не надо!

Проброс портов зделай. Настроки виртуалки --- сеть --- дополнительно --- проброс портов.
 

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28
так делать не надо!

Проброс портов зделай. Настроки виртуалки --- сеть --- дополнительно --- проброс портов.
Вроде это на виртуалбоксе так. На вмаре такого нет.
 

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28

Planelion

Любопытный
Пользователь
9 Июн 2012
255
55
28
30
Как я понел твои друзья заходят только те у которых такойже провайдер (интернета) значет у тебя локальная сеть?

p/s Простите за мой Французский
 

Juzilkree

Злостный отаку
Команда форума
Администратор
29 Ноя 2012
1.943
731
158
37
www.dyndev.ru
Тип подключения укажи "Сетевой мост" с твоей сетевой платой.
Сетевой мост включают тогда когда у тебя стоит рутер. Если рутера нету включают NAT.
Ещё есть полезная команда ifconfig.
 

Planelion

Любопытный
Пользователь
9 Июн 2012
255
55
28
30
Сетевой мост включают тогда когда у тебя стоит рутер. Если рутера нету включают NAT.
Ещё есть полезная команда ifconfig.
Да используй эту команду и покажи нам что у тебя он пишет
 

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28
Сетевой мост включают тогда когда у тебя стоит рутер. Если рутера нету включают NAT.
Ещё есть полезная команда ifconfig.
Вот что я сейчас сделал. Включил NAT посмотрел ip (про ifconfig знаю),сделал проброс портов "80" и "29000". Перезапускаю машину. Пишу ifconfig и мне пишет вместо моего ип,ничего. На регистрацию даже у меня не заходит по ип на который я делал проброс (тоесть ип виртуалки).
 

Ghost

Пользователь
Пользователь
12 Май 2012
25
0
8
28
Странно. У тебя Провайдер домалинк?
Нет,другой. У меня проблем с открытием портов на компе небыло. Мне на компе стоило только выключить брендмаузер. Пытался выключить его на юбунте по гайду выше,пишет,что такой дериктории нет.
 
Статус
В этой теме нельзя размещать новые ответы.

Пользователи онлайн

Последние ресурсы

Статистика форума

Темы
3.838
Сообщения
21.203
Пользователи
7.648
Новый пользователь
Hastino